Tutoriels > Tutoriels & Astuces Excel > Fonctions & Formules > Nommer une Plage de Cellules

Nommer une Plage de Cellules

Publié par Mth le 05-12-2008 (76137 lectures)

Nommer une Plage de Cellules

Nommer des cellules ou plages de cellules permet d'obtenir des formules souvent plus courtes mais surtout plus lisibles.

Cela permet également d'utiliser une plage fixe afin de pouvoir copier les formules à un autre emplacement, un peu l'équivalent des références absolues abordées dans l'article précédent .




Pour nommer une plage de cellules

Prenons l'exemple de la plage de cellules B3:E7 que nous allons nommer "MaPlage"...

Méthode 1


  1. Sélectionnez la plage de cellules B3:E7

    Nommer une plage 1

  2. Cliquez dans le menu Insertion / Nom / Définir... :

    Nommer une plage 2

  3. Saisissez le nom souhaité pour cette plage :

    Le nom (sans espace) peut être composé de lettres, chiffres (sauf en 1er caractère) et du caractère underscore _

    Nommer une plage 3
    Remarque : il est possible de modifier la zone « Fait référence à: ».

  4. Validez par OK.



Méthode 2


  1. Sélectionnez la plage de cellules B3:E7 (comme dans la Méthode 1 ci-dessus)

  2. Saisissez directement le nom dans la 2one des Noms :

    Nommer une plage 4

  3. Terminez par la touche Entrée.




Pour accéder aux zones nommées ou les retrouver dans un classeur

  1. Cliquez dans le menu Insertion / Nom / Définir..., la boîte de dialogue « Définir un nom » présente la liste des noms ainsi que leur emplacement :

    Nommer une plage 5

    Pour supprimer un nom, il suffit de le sélectionner dans la liste et de cliquer sur Supprimer.

  2. Ou bien dérouler tout simplement la liste de la Zone des Noms :

    Nommer une plage 6

    Dans notre exemple, si vous choisissez « MaPlage » dans la liste, la plage B3:E7 sera automatiquement sélectionnée.


Nb: et à l'inverse, si vous sélectionnez manuellement la plage B3:E7, le nom MaPlage apparaîtra automatiquement dans la Zone des Noms.


Remarque :
En écrivant une formule, si nous insérons les plages en les sélectionnant à la souris, c'est le nom de la plage « MaPlage » qui sera inséré au lieu de son adresse « B3:E7 ».

Ainsi, dans notre exemple, la formule suivante :

Formule Excel :

=NBVAL(B3:E7)

deviendrait :


Formule Excel :

=NBVAL(MaPlage)



Astuce Astuce

 Si vous appliquez un zoom très faible (25%) à votre feuille, vous pourrez apercevoir globalement l'ensemble des zones nommées :


Nommer une plage 7



Exemple de lisibilité des Formules

Soit le tableau suivant :

Nommer une plage 8

En C108, la formule est :

Formule Excel :

=SOMMEPROD((C101:C106)*(D101:D106)*(1-E101:E106))

Tandis qu'en renommant les plages comme suit :


Nommer une plage 9

En C108, la formule deviendra :

Formule Excel :

=SOMMEPROD(Qté*Prix*(1-Remise))

Cette formule devient beaucoup plus facile à lire ainsi, non ?

 


Utilité d'un Nom pour figer une cellule ou une plage dans une formule

Cette fois, nous prendrons l'exemple suivant pour appliquer un taux d'inflation à un ensemble de prix :


Nommer une plage 10

La cellule E133 étant nommée « Inflation », une fois la formule inscrite en E137, on peut la tirer vers le bas (ou la copier-coller sur les lignes du dessous).

 

Auteur de cet article : Mth

Retrouvez le dossier complet comprenant ces 3 articles :
 
 
 ...dans un classeur disponible en téléchargement : Références aux cellules ou plages .

 

Pour toutes vos questions ou si vous rencontrez des difficultés, n'hésitez pas à rejoindre nos Forums de Discussions !

Tags Tutoriel   Fonction   Formule   Cellule   Plage   Références   NBVAL()  

 

Autres articles dans cette catégorie Publié le Vues
Rechercher une Fonction 28-05-2013 4475
T() - Tester et renvoyer du texte 02-07-2012 15042
EPURAGE() - Supprimer certains caractères indésirables 02-06-2012 36694
REMPLACER() - Echanger une chaîne de caractères par une autre 02-06-2012 14595
CTXT() - Convertir un nombre en texte 23-05-2012 49337
REPT() - Répéter des caractères un certain nombre de fois 26-04-2012 14952
L'Assistant Somme Conditionnelle 01-11-2011 10184
CELLULE() - Nom de l'onglet, du fichier ou du répertoire dans une cellule 03-10-2010 45877
EXACT() - Comparer deux chaînes de texte 26-04-2010 66663
Purgez les espaces inutiles ! 05-04-2010 98339
SUPPRESPACE() - Supprimer les espaces inutiles dans une cellule 05-04-2010 46559
STXT() - Extraire une chaîne de caractères au sein d'une autre 13-03-2010 124658
CHERCHE() TROUVE() - Retourne la position d'une chaîne de caractères 04-01-2010 101598
NBCAR() - Compter les caractères d'une chaîne de texte ou d'une plage de cellules 21-11-2009 24225
SUBSTITUE() - Remplacer une chaîne de texte par une autre 08-11-2009 115091
CAR() - CODE() : Utilisation des codes caractères 25-10-2009 27538
CONCATENER() - Assembler plusieurs chaînes de texte en une seule. 10-10-2009 26030
TEXTE() - Convertir une valeur numérique en texte formaté 29-09-2009 80257
DROITE() - GAUCHE() : Extraire les premiers ou derniers caractères d'une chaîne. 12-09-2009 147782
MAJUSCULE() - MINUSCULE() - NOMPROPRE(): Modifier la casse d'un texte 23-08-2009 7719
CNUM() - Convertir une chaîne en valeur numérique 19-08-2009 45708
DATEDIF() : Calculer la différence entre deux dates 26-07-2009 106877
Nommer une Plage Dynamique 06-12-2008 60433
Nommer une Plage de Cellules 05-12-2008 76138
Références Relatives & Absolues 05-12-2008 15894
Formule pour Nombres Premiers 29-08-2007 13992