Formule, simplification
#1
Débutant XLPages

Inscription: 07/10/2014
De PARIS

Messages: 19

Système d'exploitation:
PC
Version Excel utilisée:
2010
Posté le : 14-12 13h33

Bonjour à vous,

 

Les données du problème :
- Est-il possible de simplifier la formule que j’ai ajouté en colonne « X,Y et Z » ?

 

En colonne « C » du fichier joint, je rend la valeur du code (colonne A), en valeur « UNIQUE », puis je transpose les données de la colonne « B » sur une seule ligne colonne « D à W », par la formule
=SI(COLONNES($D$1:D$1)<=NB.SI(Test!$A$3:$A$47;$C3);DECALER($A$2;EQUIV($C3;Test!$A$3:$A$47;0)+COLONNE(A$1)-1;1);"")
Formule recopier vers la droite puis vers le bas.

 

Dans la colonne « X,Y et Z », l’objectif est de compter le nombre de fois ou la lette « C, L ou N » est présente dans chaque ligne de « D à W »

 

J’ai mis la formule ci-dessous en colonne "X" et je souhaite savoir si il est possible de simplifier cette formule !

 

=NBCAR(D3)-NBCAR(SUBSTITUE(D3;"C";""))+NBCAR(E3)-NBCAR(SUBSTITUE(E3;"C";""))+NBCAR(F3)-NBCAR(SUBSTITUE(F3;"C";""))+NBCAR(G3)-NBCAR(SUBSTITUE(G3;"C";""))+NBCAR(H3)-NBCAR(SUBSTITUE(H3;"C";""))+NBCAR(I3)-NBCAR(SUBSTITUE(I3;"C";""))+NBCAR(J3)-NBCAR(SUBSTITUE(J3;"C";""))+NBCAR(K3)-NBCAR(SUBSTITUE(K3;"C";""))+NBCAR(L3)-NBCAR(SUBSTITUE(L3;"C";""))+NBCAR(M3)-NBCAR(SUBSTITUE(M3;"C";""))+NBCAR(N3)-NBCAR(SUBSTITUE(N3;"C";""))+NBCAR(O3)-NBCAR(SUBSTITUE(O3;"C";""))+NBCAR(P3)-NBCAR(SUBSTITUE(P3;"C";""))+NBCAR(Q3)-NBCAR(SUBSTITUE(Q3;"C";""))+NBCAR(R3)-NBCAR(SUBSTITUE(R3;"C";""))+NBCAR(S3)-NBCAR(SUBSTITUE(S3;"C";""))+NBCAR(T3)-NBCAR(SUBSTITUE(T3;"C";""))+NBCAR(U3)-NBCAR(SUBSTITUE(U3;"C";""))+NBCAR(V3)-NBCAR(SUBSTITUE(V3;"C";""))+NBCAR(W3)-NBCAR(SUBSTITUE(W3;"C";""))

Bien cordialement,

Pièce jointe:
xlsx Copie de Test maquette.xlsx   [ Taille: 12.93 Ko - Téléchargements: 29 ]
Hors Ligne
Rapport   Haut 

Re: Formule, simplification
#2
Débutant XLPages

Inscription: 14/12/2016
De Périgueux

Messages: 3

Système d'exploitation:
PC
Version Excel utilisée:
2003-2010
Posté le : 14-12 17h52

Bonjour,

 

En X3 pour la lettre C

 

SOMMEPROD((NBCAR(D3:W3)-NBCAR(SUBSTITUE(D3:W3;"C";""))))

 

exemple dans ton fichier en retour

 

Cdt

 

 

Pièce jointe:
xlsx Copie de Test maquette.xlsx   [ Taille: 14.72 Ko - Téléchargements: 34 ]
Hors Ligne
Rapport   Haut 

Re: Formule, simplification
#3
Accro XLPages

Inscription: 17/08/2007
De Québec, Canada

Messages: 180

Système d'exploitation:
PC
Version Excel utilisée:
Excel 2003, 2007 (FR) & MsProject 2003
Posté le : 14-12 22h30

Salut le Forum

 

En X3, à recopier vers la droite et vers le bas.

=SOMMEPROD((NBCAR($D3:$W3)-NBCAR(SUBSTITUE($D3:$W3;DROITE(X$1;1);""))))

Mytå


Merci, de donner un retour à votre question, nous ne sommes pas des robots. [GMT - 5]
Le travail d'équipe est essentiel. En cas d'erreur, ça permet d'accuser quelqu'un d'autre.
Hors Ligne
Rapport   Haut 

Re: Formule, simplification
#4
Débutant XLPages

Inscription: 07/10/2014
De PARIS

Messages: 19

Système d'exploitation:
PC
Version Excel utilisée:
2010
Posté le : 15-12 11h27

Bonjour à vous,

Infiniment merci, cela fonctionne très bien !

Autre question, ma formule en "D3" recopier vers la droite puis vers le bas "=SI(COLONNES($D$1:D$1)<=NB.SI(Test!$A$3:$A$47;$C3);DECALER($A$2;EQUIV($C3;Test!$A$3:$A$47;0)+COLONNE(A$1)-1;1);"")"

Tiens t-elle bien la route ?

j'ai rendu le code de la colonne "A" en code unique sur la colonne "C", (suppression des doublons), pour faire la transposition.

Mon fichier original fait 80 0000 lignes avec mes 20 colonnes, le calcul est très long !!

Y'a t-il un moyen de simplifier aussi cette formule ?

Bien cordialement,

 

Hors Ligne
Rapport   Haut 

Re: Formule, simplification
#5
Débutant XLPages

Inscription: 07/10/2014
De PARIS

Messages: 19

Système d'exploitation:
PC
Version Excel utilisée:
2010
Posté le : 15-12 11h28

Bonjour à vous,

Infiniment merci, cela fonctionne très bien !

Autre question, ma formule en "D3" recopier vers la droite puis vers le bas "=SI(COLONNES($D$1:D$1)<=NB.SI(Test!$A$3:$A$47;$C3);DECALER($A$2;EQUIV($C3;Test!$A$3:$A$47;0)+COLONNE(A$1)-1;1);"")"

Tiens t-elle bien la route ?

j'ai rendu le code de la colonne "A" en code unique sur la colonne "C", (suppression des doublons), pour faire la transposition.

Mon fichier original fait 80 0000 lignes avec mes 20 colonnes, le calcul est très long !!

Y'a t-il un moyen de simplifier aussi cette formule ?

Bien cordialement,

Hors Ligne
Rapport   Haut 

Re: Formule, simplification
#6
Débutant XLPages

Inscription: 14/12/2016
De Périgueux

Messages: 3

Système d'exploitation:
PC
Version Excel utilisée:
2003-2010
Posté le : 16-12 08h39

Bonjour,

 

Tu peux déjà supprimer les colonnes D à W

 

Toutefois sommeprod est une fonction matricielle gourmande en ressources avec 80 000 lignes tu ne peux pas espérer un gain de temps de traitement notable. 

 

Ton fichier avec formule modifiée

 

Cdt

Pièce jointe:
xlsx Copie de Test maquette_2.xlsx   [ Taille: 12.74 Ko - Téléchargements: 32 ]
Hors Ligne
Rapport   Haut 

Re: Formule, simplification
#7
Débutant XLPages

Inscription: 07/10/2014
De PARIS

Messages: 19

Système d'exploitation:
PC
Version Excel utilisée:
2010
Posté le : 16-12 10h25

Infiniment merci.

Bonne et agréable journée

Pascal

Hors Ligne
Rapport   Haut 

Re: Formule, simplification
#8
Débutant XLPages

Inscription: 07/08/2009

Messages: 13

Système d'exploitation:
PC
Version Excel utilisée:
2003, 2016
Posté le : 29-12 13h41

Bonjour à tous,

Une formule plus simple mais toujours avec SOMMEPROD en X3 (pour le "C"):

=SOMMEPROD(--(DROITE($D3:$W3;1)="C"))

Cordialement

Hors Ligne
Rapport   Haut 

Re: Formule, simplification
#9
Débutant XLPages

Inscription: 07/10/2014
De PARIS

Messages: 19

Système d'exploitation:
PC
Version Excel utilisée:
2010
Posté le : 02-01 22h06

Bonjour,

Merci à vous.

Bien cordialement,

Hors Ligne
Rapport   Haut 


Vous pouvez voir les sujets.
Vous ne pouvez pas débuter de nouveaux sujets.
Vous ne pouvez pas répondre aux contributions.
Vous ne pouvez pas éditer vos contributions.
Vous ne pouvez pas effacez vos contributions.
Vous ne pouvez pas ajouter de nouveaux sondages.
Vous ne pouvez pas voter en sondage.
Vous ne pouvez pas attacher des fichiers à vos contributions.
Vous ne pouvez pas poster sans approbation.

[Recherche avancée]


Qui consulte actuellement ce sujet ?   1 Utilisateur(s) anonymes