fonction N
#1
Débutant XLPages

Inscription: 31/05/2007

Messages: 12

Posté le : 01-06-2007 19h53
Salut le forum,

L'échange à propos de la fonction "N" m'intéresse ;
comme il s'écarte de la stricte application matricielle,
je crois habile de créer un nouveau fil.

Ci-dessous le fac similé d'un mini classeur Excel:
Après quelques essais, je vois :
-----cA----cB-----cC----cD
l1--ID---val------=-------formules
l2--A--------------1------{=SOMME(($A2=$A$4:$A$7)*($B$4:$B$7))}
l3------------------0------=SOMMEPROD(($A2=$A$4:$A$7);($B$4:$B$7))
l4--A----1---------1------=SOMMEPROD(n($A2=$A$4:$A$7);($B$4:$B$7))
l5--C----2
l6--G----3
l7--T----4

Il semble que selon l'usage dans "{somme}" ou dans "sommeprod",
le résultat soit différent.
NB1 :
J'ai soupçonné que les machines/versions réagissent différemment.
pfuit rien de probant pour moi.
NB2 :
j'ai cherché autour des options de transition sans rien trouver qui me convainque.

Cela exite-t-il la curiosité de quelqu'un ?

N'il y avait-il pas une vieille fonstion T symétrique de N ?

Jacques
Hors Ligne
Rapport   Haut 

Re: fonction N
#2
Accro XLPages

Inscription: 09/05/2007
De Courcelles-les-Montbéliard

Messages: 286

Système d'exploitation:
PC & Mac
Version Excel utilisée:
Mac 2004 - 2011, et PC 2003 - 2010
Posté le : 01-06-2007 21h33
Bonsoir Jacques

Dans la formule =SOMMEPROD(($A2=$A$4:$A$7);($B$4:$B$7))

La première matrice qui est le résultat par la comparation, elle contient une valeur logique, VRAI ou FAUX. SOMMEPROD va multiplier chaque valeurs de matrice pour en faire la totalisation.

Dans Excel, la valeur logique VRAI est considérée comme un 1, et FAUX comme un 0. Nous pouvons le vérifier en tapant cette formule dans une cellule =VRAI()*1 ou =FAUX()*1

Ce principe de convertion n'est pas opéré par la fonction SOMMEPROD d'Excel lors d'une multiplication entre deux matrices d'argument différent.
C'est pour cela que la formule retourne 0.

Dans la formule =SOMMEPROD(N($A2=$A$4:$A$7);($B$4:$B$7)), la fonction N provoque la conversion de la matrice comme le ferait ($A2=$A$4:$A$7)*1, le première matrice contient donc que des données numériques, pour le vérifier il suffit de sélectionner les cellules D4:D7, et de saisir la barre de formule, la formule suivante =N(A4:A7=A2) en la validant en tant que matricielle.

@+Jean-Marie
Hors Ligne
Rapport   Haut 

Re: fonction N
#3
Accro XLPages

Inscription: 09/05/2007
De Courcelles-les-Montbéliard

Messages: 286

Système d'exploitation:
PC & Mac
Version Excel utilisée:
Mac 2004 - 2011, et PC 2003 - 2010
Posté le : 02-06-2007 01h05
Re

Concernant la formule N pour le Texte, oui il y toujours la fonction T.
Elle retourne le texte de la cellule si le contenu de la cellule est du Texte, si c'est numérique retourne "", si c'est une valeur logique retourne "".

@+Jean-Marie
Hors Ligne
Rapport   Haut 

fonction N
#4
Débutant XLPages

Inscription: 31/05/2007

Messages: 12

Posté le : 04-06-2007 22h43
Bonsoir Jean-Marie,
salut au forum,

Merci de ces précisions concernant N.
Et aussi concernant SOMMEPROD.

Jacques
Hors Ligne
Rapport   Haut 


Vous pouvez voir les sujets.
Vous ne pouvez pas débuter de nouveaux sujets.
Vous ne pouvez pas répondre aux contributions.
Vous ne pouvez pas éditer vos contributions.
Vous ne pouvez pas effacez vos contributions.
Vous ne pouvez pas ajouter de nouveaux sondages.
Vous ne pouvez pas voter en sondage.
Vous ne pouvez pas attacher des fichiers à vos contributions.
Vous ne pouvez pas poster sans approbation.

[Recherche avancée]


Qui consulte actuellement ce sujet ?   1 Utilisateur(s) anonymes