PLAGE DYNAMIQUE
#1
Débutant XLPages

Inscription: 11/11/2018
De France

Messages: 1

Système d'exploitation:
PC
Version Excel utilisée:
2013,2016
Posté le : 11-11 11h51

Bonjour

suite à l'excellent tuto (très bien présenté vraiment) sur la plage dynamique avec l'exemple de la fonction somme prod et l'utilisation de Nbval et decaler, j'ai essayé d'adapter ça avec une plage en deux dimensions pour la fonction recherchev.

Je veux seulement paramétrer ma plage de recherche dans un tableau et non plus une colonne.

Dans un fichier Objet, je je veux rechercher une valeur dans une plage qui appartient à un autre fichier, lequel est dynamique pour sa dernière ligne:

= RECHERCHEV(A2;fichier source\feuillesource!$A$8:$DU$2656;6;faux)

..et on tire sur A2, A3, etc pour remplir un nouvau tableau.

 

Le fichier source est donc visité sur sa plage $A$8:DU2656, mais ce 2656 change tout le temps.

 

Comment dois je paramétrer cette plage dynamiquement ?

Je sais déterminer le nombre de cellules non vide du tableau, je peux même en mettre la valeur ds une cellule en en tête de ce tableau de sorte à ce que par exemple A6 (disponible car les données démarrent à 8) soit égal à 2656, ou même directement A8:DU2656 à l'aide de la fonction concatener

=CONCATENER("A";8;":DU";A3)

avec A3= {=MAX(SI(NON(ESTVIDE(C1:C3276));LIGNE(C1:C3276)))}

où là, c'est vrai 3276 est arbitrairement lointain; j'aurais pu utiliser non vide

 

Bref, je veux rendre pour ma recherche dans le fichier cible, la plage DU2656 dynamique en terme de nombre de lignes.

J'espère que je suis clair ?

 

Hors Ligne
Rapport   Haut 

Re: PLAGE DYNAMIQUE
#2
Accro XLPages

Inscription: 09/01/2008
De Montréal, Québec

Messages: 461

Système d'exploitation:
PC
Version Excel utilisée:
97 à 2016
Posté le : 12-11 17h44

Bonjour Polygos et bienvenue au forum,

 

Si j'ai bien compris tu cherches à monter une plage dynamique de dimension 2, bien.

 

S'agissant de la façon dont est structurée la plage de données ...

Je sais déterminer le nombre de cellules non vide du tableau, je peux même en mettre la valeur ds une cellule en en tête de ce tableau de sorte à ce que par exemple A6 (disponible car les données démarrent à 8) soit égal à 2656

... ce n'est pas clair.

 

  • Les données ne semblent pas tabulaire, le sont-elle?
  • Y a-t-il des noms de champs ou sommes-nous en présence d'une java entre B52, AK47 ou A380?

 

Bref un petit classeur exemple serait indiqué.

 

Cordialement,

 

Guy

 


Hors Ligne
Rapport   Haut 


Vous pouvez voir les sujets.
Vous ne pouvez pas débuter de nouveaux sujets.
Vous ne pouvez pas répondre aux contributions.
Vous ne pouvez pas éditer vos contributions.
Vous ne pouvez pas effacez vos contributions.
Vous ne pouvez pas ajouter de nouveaux sondages.
Vous ne pouvez pas voter en sondage.
Vous ne pouvez pas attacher des fichiers à vos contributions.
Vous ne pouvez pas poster sans approbation.

[Recherche avancée]


Qui consulte actuellement ce sujet ?   1 Utilisateur(s) anonymes