Créer une liste verticale des noms d'onglets d'un fichier Excel
#1
Débutant XLPages

Inscription: 26/07/2018
De Paris

Messages: 1

Système d'exploitation:
pc
Version Excel utilisée:
2010
Posté le : 26-07 23h40

Bonjour,

 

J'ai 3 questions :

 

1°) J'ai un fichier Excel avec 61 onglets. Le 1er onglet doit contenir verticalement en colonne B la liste des noms des 60 autres onglets.

J'ai bien utilisé la formule ci-dessous, mais elle me renvoie le nom de l'onglet sur lequel je suis et je ne sais pas quoi modifier pour copier/coller la formule dans toute la colonne.

=DROITE(CELLULE("filename";A1);NBCAR(CELLULE("filename";A1))-CHERCHE("]";CELLULE("filename";A1))) ;

 

Comment obtenir la liste de tous les onglets sans faire de macro ni de programmation, mais par une formule ?

 

2°) En colonne C du 1er onglet, j'aimerais récupérer automatiquement le contenu de chaque cellule D3 de chaque onglet dont le nom est en colonne B, sans avoir à pointer manuellement chacune de ces cellules (60 fois).

 

Comment faire ?

 

3°) Comment nommer par un n° automatiquement chaque onglet et qu'il se mette à jour si je déplace un onglet ?

 

L'idée, c'est que la maintenance de mon fichier en cas d'ajout d'onglet ou de déplacement d'onglet puisse se faire avec le moins de manipulations possibles.

 

Merci d'avance pour votre aide.

Edité par Megara le 27/07/2018 11:19:47
Hors Ligne
Rapport   Haut 

Re: Créer une liste verticale des noms d'onglets d'un fichier Excel
#2
Débutant XLPages

Inscription: 07/08/2009

Messages: 17

Système d'exploitation:
PC
Version Excel utilisée:
2003, 2016
Posté le : 08-08 11h54

Bonjour,

 

Solution trouvée dans le Net:

 

Créer un nom par 'insertion / nom / définir', par exemple nomFeuilles et dans

'Fait référence à' saisir : 

=LIRE.CLASSEUR(1)

en A1: 

=INDEX(nomFeuilles;LIGNE())

à tirer vers le bas. 
(si tu démarres en ligne 3 remplacer LIGNE() par LIGNE()-2 etc) 

* Si tu ne veux que le nom de la feuille sans la référence au classeur: 

 

=STXT(INDEX(nomFeuilles;LIGNE());CHERCHE("]";INDEX(nomFeuilles;LIGNE()))+1;30)

 

* Et si tu ne veux pas afficher les #REF!, tu peux ajouter un test sur

nbval(nomFeuilles) qui te donne le nombre de feuilles du classeur 
 

=SI(LIGNE()>NBVAL(nomFeuilles);"";STXT(INDEX(nomFeuilles;LIGNE());CHERCHE("]";INDEX(nomFeuilles;LIGNE()))+1;30))

 

Lien de la solution: http://www.commentcamarche.net/forum/ ... -des-onglets-d-un-fichier 

 

Cordialement

Edité par hben le 09/08/2018 18:18:41
Hors Ligne
Rapport   Haut 


Vous pouvez voir les sujets.
Vous ne pouvez pas débuter de nouveaux sujets.
Vous ne pouvez pas répondre aux contributions.
Vous ne pouvez pas éditer vos contributions.
Vous ne pouvez pas effacez vos contributions.
Vous ne pouvez pas ajouter de nouveaux sondages.
Vous ne pouvez pas voter en sondage.
Vous ne pouvez pas attacher des fichiers à vos contributions.
Vous ne pouvez pas poster sans approbation.

[Recherche avancée]


Qui consulte actuellement ce sujet ?   1 Utilisateur(s) anonymes