Recherche des espaces dans une cellule de texte
#1
Débutant XLPages

Inscription: 02/04/2018
De Paris

Messages: 1

Système d'exploitation:
PC
Version Excel utilisée:
2007,2010,1016
Posté le : 02-04 19h27

Bonjour,

Dans une colonne comportant du texte, dans mon cas des patronymes", je recherche les caractères spéciaux et les affiche dans la cellule contiguë.

Pas de souci avec À Â Ä Ç É È Ê Ë Î Ï Ô Ö Ù Û Ü Ÿ Æ Œ à â ä ç é è ê ë î ï ô ö ù û ü ÿ æ œ ' - 

Pour Ö, par exemple, j'utilise la formule :

=SI((ESTNUM(TROUVE("Ö";'Noms de famille'!$A2)));"Ö";"")

 

Par contre, j'ai un souci avec les espaces, par exemple pour le patronyme "Pellissier de Féligonde de Leotoing d'Anjony" (si si, il existe

J'ai essayé 

=SI((ESTNUM(TROUVE(" ";'Noms de famille'!$A2)));"Espace";"")

=SI((ESTNUM(TROUVE((CAR(CODE(32)));'Noms de famille'!$A2)));"Espace";"")

Idem avec le code 160

Et ... rien.

Quelqu'un(e) aurait-il une idée ?

Merci d'avance smiley

Hors Ligne
Rapport   Haut 

Re: Recherche des espaces dans une cellule de texte
#2
Semi pro XLPages

Inscription: 12/06/2008
De Ile de France Sud

Messages: 127

Système d'exploitation:
PC
Version Excel utilisée:
2003
Posté le : 09-04 19h32

Bonsoir à toutes et tous

Bonsoir PAD

 

Si c'est toujours d'actualité, peux tu essayer ceci :

=SI(ESTERREUR((CHERCHE(" ";A2;1)))="FAUX";"";"espace")

Dis nous

Eric

 

Hors Ligne
Rapport   Haut 


Vous pouvez voir les sujets.
Vous ne pouvez pas débuter de nouveaux sujets.
Vous ne pouvez pas répondre aux contributions.
Vous ne pouvez pas éditer vos contributions.
Vous ne pouvez pas effacez vos contributions.
Vous ne pouvez pas ajouter de nouveaux sondages.
Vous ne pouvez pas voter en sondage.
Vous ne pouvez pas attacher des fichiers à vos contributions.
Vous ne pouvez pas poster sans approbation.

[Recherche avancée]


Qui consulte actuellement ce sujet ?   1 Utilisateur(s) anonymes