SOMME.SI.ENS ou SOMMEPROD ?
#1
Débutant XLPages

Inscription: 24/09/2015
De Alger

Messages: 18

Système d'exploitation:
PC
Version Excel utilisée:
2010
Posté le : 07-08 21h23

Je reprends mon texte pour une erreur dans le titre

 

Bonsoir,
Ma question  porte sur NB.SI.ENS et SOMME.SI.ENS avec un fichier pour illustrer la solution recherchée.
Vous serez sympas d'y jeter un coup d'oeil !
Merci à tous ceux et celles qui font vivre ce Forum. 
Cordialement 
Fath

Pièce jointe:
zip Support.ZIP   [ Taille: 36.06 Ko - Téléchargements: 12 ]
Hors Ligne
Rapport   Haut 

Re: SOMME.SI.ENS ou SOMMEPROD ?
#2
Webmestre

Inscription: 18/05/2006
De Saône-et-Loire (71)

Messages: 1461

Système d'exploitation:
PC
Version Excel utilisée:
97, 2000, 2002, 2003, 2007, 2010, 2013, 2016
Posté le : 07-08 23h12

Bonsoir Fath, le Forum,

 

Si j'ai bien interprété ton souhait, je pense que tu étais presque sur la bonne solution ...

 

En F13, j'aurais plutot inscrit :

=SOMME.SI.ENS(Ventes!$F:$F;Ventes!$B:$B;"1";Ventes!$C:$C;C13)

Bien cordialement 


Didier_mDF
Image redimensionnée
Le Webmaster

La réponse vous satisfait ? Merci de revenir solder le sujet en [résolu], voir ce lien
Hors Ligne
Rapport   Haut 

Re: SOMME.SI.ENS ou SOMMEPROD ?
#3
Débutant XLPages

Inscription: 24/09/2015
De Alger

Messages: 18

Système d'exploitation:
PC
Version Excel utilisée:
2010
Posté le : 08-08 16h31

Bonjour Didier,

 

Merci pour ta formule, elle fonctionne bien, et avec de l'aide j'ai pu la généraliser en faisant référence aux titres des colonnes de la récap. comme suit

=SOMME.SI.ENS(Ventes!$F:$F;Ventes!$B:$B;[@Mois];Ventes!$C:$C;[@Code])

 

et encore mieux avec les titres des colonnes des deux feuilles.

SOMME.SI.ENS(Ventes[Quantité];Ventes[Mois];[@Mois];Ventes[Code];[@Code])

 

Cordialement

Fath

Hors Ligne
Rapport   Haut 


Vous pouvez voir les sujets.
Vous ne pouvez pas débuter de nouveaux sujets.
Vous ne pouvez pas répondre aux contributions.
Vous ne pouvez pas éditer vos contributions.
Vous ne pouvez pas effacez vos contributions.
Vous ne pouvez pas ajouter de nouveaux sondages.
Vous ne pouvez pas voter en sondage.
Vous ne pouvez pas attacher des fichiers à vos contributions.
Vous ne pouvez pas poster sans approbation.

[Recherche avancée]


Qui consulte actuellement ce sujet ?   1 Utilisateur(s) anonymes