Forums XLPages

Tous les messages (hben)

1 2 »
Re: Copier/coller une image sur une autre feuille et l'adapter au cadre de destination
#1
Débutant XLPages

Inscription: 07/08/2009

Messages: 14

Système d'exploitation:
PC
Version Excel utilisée:
2003, 2016
Posté le : 16-08 21h03

Bonjour à tous, bonjour Eric

Un essai dans le fichier joint ...

Cordialement

 

Lien: http://www.mediafire.com/file/52615so ... a/Fiche_ProduitForum.xlsm

Hors Ligne
Rapport   Haut 

Re: N° Tarif par Client
#2
Débutant XLPages

Inscription: 07/08/2009

Messages: 14

Système d'exploitation:
PC
Version Excel utilisée:
2003, 2016
Posté le : 05-03 14h31

Bonjour à tous,

 

Je ne trouve aucun problème à insérer ta formule dans les cellules indiquées, même si tes plages $H$4:$H$17 et $A$4:$A$7 utilisées dans la formule n'ont pas la même hauteur... Les formules nouvellement insérées concernent toutes les colonnes H et A...

 

Cordialement

Pièce jointe:
xlsx N° Tarif par Client.xlsx   [ Taille: 38.81 Ko - Téléchargements: 33 ]
Hors Ligne
Rapport   Haut 

Re: classement de donnees
#3
Débutant XLPages

Inscription: 07/08/2009

Messages: 14

Système d'exploitation:
PC
Version Excel utilisée:
2003, 2016
Posté le : 04-03 15h49

Bonjour à tous,

Moi aussi j'ai du mal à comprendre, mais je propose la formule suivante en Q3 (glissée vers la droite à la cellule X3 puis vers le bas):

=RANG(I3;$I3:$P3;1)

Cordialement

Hors Ligne
Rapport   Haut 

Re: Formule, simplification
#4
Débutant XLPages

Inscription: 07/08/2009

Messages: 14

Système d'exploitation:
PC
Version Excel utilisée:
2003, 2016
Posté le : 29-12 13h41

Bonjour à tous,

Une formule plus simple mais toujours avec SOMMEPROD en X3 (pour le "C"):

=SOMMEPROD(--(DROITE($D3:$W3;1)="C"))

Cordialement

Hors Ligne
Rapport   Haut 

Re: Suppression de chiffres ou nombres associés à un suffixe
#5
Débutant XLPages

Inscription: 07/08/2009

Messages: 14

Système d'exploitation:
PC
Version Excel utilisée:
2003, 2016
Posté le : 26-11-2015 19h15

Bonjour à tous, bonjour turfman

 

Voir fichier attaché, pas trouver mieux...

 

Cordialement

 

 

Pièce jointe:
xlsm Classeur1.xlsm   [ Taille: 15.78 Ko - Téléchargements: 98 ]
Hors Ligne
Rapport   Haut 

Re: mise en forme contionnel de date
#6
Débutant XLPages

Inscription: 07/08/2009

Messages: 14

Système d'exploitation:
PC
Version Excel utilisée:
2003, 2016
Posté le : 26-11-2015 19h05

Bonjour,

 

La formule de mise en forme suivante peut répondre à la quention:

=SOMMEPROD(('P61'!P3:P25<AUJOURDHUI())*LIGNE($1:$23))

Cordialement

Hors Ligne
Rapport   Haut 

Re: Erreur d'exécution '91'
#7
Débutant XLPages

Inscription: 07/08/2009

Messages: 14

Système d'exploitation:
PC
Version Excel utilisée:
2003, 2016
Posté le : 25-04-2015 19h08

Bonjour à tous,

 

On aimerai bien savoir quel est l'intérêt de ce code (un filtrage sur trois colonnes selon un terme recherché qui se termine par la commande "ActiveSheet.ShowAllData" qui réaffiche le tout)...

L'erreur est due (du moins je crois) à l'absence du terme recherché dans la colonne précédente (colonne B) après filtrage de cette colonne... Tu pourras faire un petit essai en éliminant le terme recherché dans la première colonne et exécuter le code, l'erreur sera dans le filtrage de la colonne B...
N'y a-t-il pas erreur dans les lignes du code suivantes:

ActiveSheet.Range("A:A").AutoFilter Field:=2, Criteria1:=StrRecherche

ActiveSheet.Range("A:A").AutoFilter Field:=3, Criteria1:=StrRecherche

Filtre sur colonne A selon les champs 2 et 3  ???

 

De préférence joindre le fichier concerné pour faire nos essais...

 

Cordialement

Hors Ligne
Rapport   Haut 

Re: Compter les cellules de couleur
#8
Débutant XLPages

Inscription: 07/08/2009

Messages: 14

Système d'exploitation:
PC
Version Excel utilisée:
2003, 2016
Posté le : 24-04-2015 12h07

Bonjour à tous,

 

Pour une première solution, on ajoute la ligne suivante au début du code de la fonction personnalisée  "NbColor":

Application.Volatile

et on ajoute le code suivant au "code" de la feuille où la fonction "NbColor" est appliquée:

Private Sub Worksheet_SelectionChange(ByVal Target As Range)
    Application.Calculate
End Sub

Cordialement

Hors Ligne
Rapport   Haut 

Re: Problème avec date et heure
#9
Débutant XLPages

Inscription: 07/08/2009

Messages: 14

Système d'exploitation:
PC
Version Excel utilisée:
2003, 2016
Posté le : 23-04-2015 00h17

Bonjour à tous,

 

Le problème est peut-être dans le format de la cellule contenant la date et l'heure, le même résultat  obtenu en utilisant le format suivant: jj/mm/aaaa"  " hh:mm;@

Changer peut-être le format en : jj/mm/aaaa hh:mm;@

 

Cordialement

Hors Ligne
Rapport   Haut 

Re: Concatener
#10
Débutant XLPages

Inscription: 07/08/2009

Messages: 14

Système d'exploitation:
PC
Version Excel utilisée:
2003, 2016
Posté le : 22-04-2015 23h57

Bonjour à tous,

 

Une formule matricielle en C2 (Validée par Ctrl+Maj+Entrée) puis à recopier vers le bas:

=$A2&INDEX($B:$B;MAX(($A$1:$A2="Total")*LIGNE($1:2)))

 

Cordialement

Hors Ligne
Rapport   Haut 

1 2 »