Rapport de message :*
 

Re: Formule, simplification

Titre du sujet : Re: Formule, simplification
par OPVA6311 le 15/12/2016 11:27:29

Bonjour à vous,

Infiniment merci, cela fonctionne très bien !

Autre question, ma formule en "D3" recopier vers la droite puis vers le bas "=SI(COLONNES($D$1:D$1)<=NB.SI(Test!$A$3:$A$47;$C3);DECALER($A$2;EQUIV($C3;Test!$A$3:$A$47;0)+COLONNE(A$1)-1;1);"")"

Tiens t-elle bien la route ?

j'ai rendu le code de la colonne "A" en code unique sur la colonne "C", (suppression des doublons), pour faire la transposition.

Mon fichier original fait 80 0000 lignes avec mes 20 colonnes, le calcul est très long !!

Y'a t-il un moyen de simplifier aussi cette formule ?

Bien cordialement,