Rapport de message :*
 

Formule, simplification

Titre du sujet : Formule, simplification
par OPVA6311 le 14/12/2016 13:33:55

Bonjour à vous,

 

Les données du problème :
- Est-il possible de simplifier la formule que j’ai ajouté en colonne « X,Y et Z » ?

 

En colonne « C » du fichier joint, je rend la valeur du code (colonne A), en valeur « UNIQUE », puis je transpose les données de la colonne « B » sur une seule ligne colonne « D à W », par la formule
=SI(COLONNES($D$1:D$1)<=NB.SI(Test!$A$3:$A$47;$C3);DECALER($A$2;EQUIV($C3;Test!$A$3:$A$47;0)+COLONNE(A$1)-1;1);"")
Formule recopier vers la droite puis vers le bas.

 

Dans la colonne « X,Y et Z », l’objectif est de compter le nombre de fois ou la lette « C, L ou N » est présente dans chaque ligne de « D à W »

 

J’ai mis la formule ci-dessous en colonne "X" et je souhaite savoir si il est possible de simplifier cette formule !

 

=NBCAR(D3)-NBCAR(SUBSTITUE(D3;"C";""))+NBCAR(E3)-NBCAR(SUBSTITUE(E3;"C";""))+NBCAR(F3)-NBCAR(SUBSTITUE(F3;"C";""))+NBCAR(G3)-NBCAR(SUBSTITUE(G3;"C";""))+NBCAR(H3)-NBCAR(SUBSTITUE(H3;"C";""))+NBCAR(I3)-NBCAR(SUBSTITUE(I3;"C";""))+NBCAR(J3)-NBCAR(SUBSTITUE(J3;"C";""))+NBCAR(K3)-NBCAR(SUBSTITUE(K3;"C";""))+NBCAR(L3)-NBCAR(SUBSTITUE(L3;"C";""))+NBCAR(M3)-NBCAR(SUBSTITUE(M3;"C";""))+NBCAR(N3)-NBCAR(SUBSTITUE(N3;"C";""))+NBCAR(O3)-NBCAR(SUBSTITUE(O3;"C";""))+NBCAR(P3)-NBCAR(SUBSTITUE(P3;"C";""))+NBCAR(Q3)-NBCAR(SUBSTITUE(Q3;"C";""))+NBCAR(R3)-NBCAR(SUBSTITUE(R3;"C";""))+NBCAR(S3)-NBCAR(SUBSTITUE(S3;"C";""))+NBCAR(T3)-NBCAR(SUBSTITUE(T3;"C";""))+NBCAR(U3)-NBCAR(SUBSTITUE(U3;"C";""))+NBCAR(V3)-NBCAR(SUBSTITUE(V3;"C";""))+NBCAR(W3)-NBCAR(SUBSTITUE(W3;"C";""))

Bien cordialement,